eagle.io setup ?

The dataTaker DT8xG Geologgers for geotechnical applications

eagle.io setup ?

Postby yzak » Thu Nov 12, 2015 4:27 pm

I was trying to setup an eagle.io account using the information from the link below
http://docs.eagle.io/en/latest/topics/d ... index.html

I have finished the setup successfully but i couldn't get any data in my eagle account
In the datataker I have a schedule with 3 thermocouples connected that scans every 5 sec and an another schedule with 5 sec exclusively for FTP.

29sv status is as follows

-30 Unload output file could not be queued for transmission because communications session queue is ful.
yzak
Apprentice
 
Posts: 12
Joined: Thu Aug 07, 2014 4:41 pm

Re: eagle.io setup ?

Postby Rudy Gunawan » Mon Nov 16, 2015 1:03 pm

Hi yzak,

Please clear communication queue (send SESSION CLEAR to the logger) and try to send FTP again.
But this time enable FTP transfer diagnostic (send P56=8 to the logger) which allow you to monitor any errors in the process.
The above process must be done on command interface (in dEX or through DeTransfer).

Send that diagnostic result to me if you found an error.

Best regards,
Rudy Gunawan
Rudy Gunawan
Guru
 
Posts: 443
Joined: Sun Apr 29, 2012 12:28 am

Re: eagle.io setup ?

Postby yzak » Wed Nov 18, 2015 7:55 pm

My program
Job Program - CONFIG
BEGIN"config"
' Generated by dEX Configuration Builder Version 1.50.167 (Firmware Version 9.16.5728)
' Target device: DT80G-3
password=""

RS1S
RA"Schedule_1"("b:",ALARMS:OV:100KB:W60,DATA:OV:1MB)5S
LOGONA
1TK("Thermocouple_1~degC",=1001CV,LM,NA)
2TK("Thermocouple_2~degC",=1002CV,LM,NA)
3TK("Thermocouple_3~degC",=1003CV,LM,NA)
RB"Schedule_2"("b:",ALARMS:OV:100KB:W60,DATA:OV:1MB)20S
LOGONB
DO{copyd dest="ftp://username:password@ftp.eagle.io:21?priority=yes&interface=" format=CSV sched=AB data=Y alarms=N start=new}
END

when I cleared the session I am getting message saying unload is complete.
but on the eagle.io side I could see that the status changes to connecting and then to downloading but no data is uploaded whatsoever.

Capture.PNG
Capture.PNG (28.3 KiB) Viewed 10746 times


reply from datataker


DT80> Thermocouple_1 25.1 degC
Thermocouple_2 23.5 degC
Thermocouple_3 23.5 degC


Unloading: CONFIG A Data (4 records) -> ftp://username-password@ftp.eagle.io:21 ... 134701.CSV
ETH SESSION: Starting (alarm/unload)
ETH SESSION: Ready (192.168.0.50)
Unload complete.
FTP: Connecting to server ftp.eagle.io (54.252.235.152)...
<< 220 Service ready
>> USER username
<< 331 USER NAME OKAY, NEED PASSWORD
>> PASS password
<< 230 USER LOGGED IN
>> TYPE I
<< 200 Type set to IMAGE NONPRINT
FTP: Connected.
>> PASV
<< 227 Entering Passive Mode (54,252,235,152,159,114)
>> STOR 227_20151117T134701.CSV.tmp091
<< 150 Opening binary mode data connection for 227_20151117T134701.CSV.tmp091
Thermocouple_1 25.0 degC
Thermocouple_2 23.5 degC
Thermocouple_3 23.4 degC

<< 226 Transfer complete for STOR 227_20151117T134701.CSV.tmp091
FTP: Transfer successful. Transferred 312 bytes.
>> DELE 227_20151117T134701.CSV
<< 550 227_20151117T134701.CSV: no such file or directory
>> RNFR 227_20151117T134701.CSV.tmp091
<< 350 File exists, ready for destination name
>> RNTO 227_20151117T134701.CSV
<< 250 RNTO command successful
>> QUIT
<< 221 Service closing control connection.
ETH SESSION: Completed
yzak
Apprentice
 
Posts: 12
Joined: Thu Aug 07, 2014 4:41 pm

Re: eagle.io setup ?

Postby Rudy Gunawan » Mon Nov 23, 2015 12:51 pm

Hi yzak,

You should not put your credential in the open forum (I have change them), please change your username and password of your FTP server.
Now go back to that diagnostic:

<< 226 Transfer complete for STOR 227_20151117T134701.CSV.tmp091
FTP: Transfer successful. Transferred 312 bytes.
>> DELE 227_20151117T134701.CSV
<< 550 227_20151117T134701.CSV: no such file or directory
>> RNFR 227_20151117T134701.CSV.tmp091
<< 350 File exists, ready for destination name
>> RNTO 227_20151117T134701.CSV
<< 250 RNTO command successful
>> QUIT
<< 221 Service closing control connection.
ETH SESSION: Completed

The above process indicates one file was delivered successfully.
It began with a creation of temporary file (*.tmp91) then check and delete the same name on csv extension (make sure no duplication of file).
Then dataTaker will re-check the existence of temporary file (RNFR) in the server and rename that temporary extension to csv extension.

The file is in your FTP server, the question is where?
Since you did not define any folder, it should be on root folder.
Please check it.

Recommendation:
Instead of using root folder, please define a specific forlder for the file.

Best regards,
Rudy Gunawan
Rudy Gunawan
Guru
 
Posts: 443
Joined: Sun Apr 29, 2012 12:28 am

Re: eagle.io setup ?

Postby yzak » Tue Nov 24, 2015 9:38 pm

Thank you rudy.
I got it to work.The file was getting delivered to my FTP Server and it was going directly in to debug.This happened because the timestamp parsing format was set to YYYY/MM/DD HH:mm:ss.sss insted of YYYY/MM/DD HH:mm:ss.SSS.
any way this was fun,thanks a lot for your support.
yzak
Apprentice
 
Posts: 12
Joined: Thu Aug 07, 2014 4:41 pm


Return to DT8xG

Who is online

Users browsing this forum: No registered users and 1 guest

cron